トップ 最新 追記

のろのろのろ雑記

2006|05|06|07|08|09|11|12|
2007|01|03|04|05|10|
2008|01|02|03|04|05|06|08|09|10|11|12|
2009|02|03|04|05|
2012|08|09|11|12|
2016|04|09|11|

2012-12-16 Mongoid: 複数のデータベースを扱う

_ [Web][Ruby] Mongoid: 複数のデータベースを扱う

class Userquake
  include Mongoid::Document
  store_in database: "p2pquake"
end

 …というふうに、 store_in をつけるだけでした。

 ただし、store_in はMongoid 3.0.0以降でないと使えません。


 もしPadrinoからMongoid 3.0.0以降を使う場合、 padrino edge(git版) を使う必要があります(padrinoとmongoid 3.0系は相性が悪い? → padrino edge(git版) なら大丈夫)。